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Introduction 
 

The TechSmith Deployment Tool is designed for Information Technology (IT) specialists or 

system administrators responsible for installing Snagit throughout an organization. The tool 

enables the administrator to customize and generate a Windows Installer Transform file (MST) 

and a BAT file. 

 

To view or customize the individual registry settings for Snagit, download the Snagit MSI 

Installation Guide from TechSmith Software Deployment & Resources. 

 

Previous Versions 
Download a previous version of the Snagit Deployment Tool Guide: 

• Snagit 2025 Deployment Tool Guide 

• Snagit 2024 Deployment Tool Guide 

• Snagit 2023 Deployment Tool Guide 

• Snagit 2022 Deployment Tool Guide 

https://www.techsmith.com/resources/enterprise-resources/
https://www.techsmith.com/wp-content/uploads/2025/09/Snagit-Deployment-Tool-Guide.pdf
https://assets.techsmith.com/Docs/Snagit-2024-Deployment-Tool-Guide.pdf
https://assets.techsmith.com/Docs/Snagit-2023-Deployment-Tool-Guide.pdf
https://assets.techsmith.com/Docs/Snagit-2022-Deployment-Tool-Guide.pdf
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Download the Deployment Tool 

1. Download the Snagit MSI Installer and the TechSmith Deployment Tool. Both are 

available from the TechSmith Software Deployment Resources page. 

Note: Always download and use the latest version of the TechSmith Deployment 

Tool, regardless of which version of the MSI Installer file you are using. 

 

2. Verify that .NET 4.7.2 is installed. Refer to .NET Framework versions and 

dependencies for details. 

 

3. Double-click the TechSmith_Deployment_Tool.exe to launch the program. 

 

 

Note: By default, the Deployment Tool generates the MST and BAT files into the same 

directory where the executable is launched. 

https://download.techsmith.com/snagit/releases/snagit.msi
https://download.techsmith.com/tscdeploymenttool/techsmith_deployment_tool.exe
https://www.techsmith.com/resources/enterprise-resources/
https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/versions-and-dependencies#net-framework-472
https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/versions-and-dependencies#net-framework-472
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Welcome Screen 

 
 

 

1. On the Welcome screen, click the Open MSI Package button. 

2. Download the Snagit MSI installer (if not done already), then click to select it. 

3. Click Open. 

 

The MSI file opens in the Deployment Tool and displays the available options for creating a 

custom MST file. 

  

https://download.techsmith.com/snagit/releases/snagit.msi
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Note: Microsoft .NET Framework, WebView2 Runtime, and Visual C++ 2019 Redistributed 

Package are required to run Snagit. These applications are not automatically installed with the 

MSI Installer so they must be installed manually before deploying the software.  

 

Install WebView2 Runtime “per machine” rather than “per-user” to ensure Snagit’s WebView2 

Check runs correctly. For installation details, see Installing the Runtime as per-machine or 

per-user from Microsoft. 

 

  

https://docs.microsoft.com/en-us/microsoft-edge/webview2/concepts/distribution#installing-the-runtime-as-per-machine-or-per-user
https://docs.microsoft.com/en-us/microsoft-edge/webview2/concepts/distribution#installing-the-runtime-as-per-machine-or-per-user
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Customize a Snagit Deployment 

Click through the tabs on the left side of the TechSmith Deployment tool to view the custom 

options available. 

 

 

The following sections describe the options available on each screen: 

• General Options 
• Disable Snagit Settings 

• Install Features Options 
• TechSmith Fuse Options 
• User Data Path Options 
• Add Components 

• Snagit Registry File Options 
• Uninstall Options  
• Install Display Options 

• Create Transform File 
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Import Settings Options 

 

You can duplicate the settings used in a previously created MST file. 

1. On the Import Settings tab, click the Open MST File button. 

2. Browse to select the transform mile (.mst). 

Note: Importing a transform file will reset your current Deployment Tool settings. 

3. Click the Open button. 

 

The Deployment Tool automatically selects the settings from the imported transform file.
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General Options 

 

Registration Information 
Enter a username (e.g. your company or organization name) and the software key. If you have 

trouble locating your software key, see License and Software Key FAQ. 

 

If you enter a software key, make sure to select the Disable online Snagit registration 

dialog option on the Disable Snagit Settings screen in the TechSmith Deployment Tool. 

 

https://support.techsmith.com/hc/en-us/articles/203732878
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Note: At launch, Snagit validates the software key on each computer over an internet 

connection. View the Activate Offline support article for instructions on how to activate offline.  

 

Installation Path 
By default, Snagit is installed to the following location on a user’s machine: 

%ProgramFiles%\TechSmith\Snagit 

 

To select a custom location, click the Browse button or enter a path to the desired directory. 

Installation Options 
• Create shortcuts on Desktop: Creates shortcuts for Snagit and Snagit Editor on the 

desktop. 

• Run Snagit when Windows starts: Starts Snagit and the Capture Window. Snagit 

Editor starts in the background. 

 

Product Language 
Select the language for Snagit: 

• ENU - English 

• DEU - German 

• ESN - Spanish 

• FRA - French 

• JPN - Japanese 

• PTB – Portuguese 

Advanced Options 

Virtualization Support 

Snagit performs optimizations when it detects it is running in a virtualized environment. The 

performance optimizations include: 

https://support.techsmith.com/hc/en-us/articles/360050288752-Activate-Snagit-Offline
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• Crosshairs are simplified when selecting an area to capture. 

 

• Shadow effect is removed. 

• Crosshair lines do not extend across the entire screen. 

• Animation around the selected area is removed. 

• The unselected area is not grayed out after a selection is made. 

 
 

• When a large desktop is detected: 

• Snagit limits visual changes across the entire desktop. 

• Snagit limits unnecessary animations. 

 

Snagit can auto-detect most environments, or you can select to always apply these 

optimizations. Select one of the following options: 

• Auto-Detect: Apply the optimizations when it detects that Snagit is running on a virtual 

machine. 

• Yes: Always apply the optimizations. 
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• No: Do not apply the optimizations. 

 

Note: It is recommended to set this option to Yes when using virtualization technologies. 

Auto Update Support 

The Snagit updater requires Windows Background Intelligent Transfer Service (BITS) to be 

enabled on the machine where Snagit is installed. You can provide a custom list of proxy 

servers for BITS to use for downloading updates.  

 

Separate each proxy server in the list by a blank space. Refer to Microsoft BITS documentation 

for more information about formatting the proxy server URL. 

 

  

https://learn.microsoft.com/en-us/windows/win32/api/bits/nf-bits-ibackgroundcopyjob-setproxysettings#remarks
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Disable Snagit Settings 
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Option Description When Should I Consider Disabling 
It? 

Automatic 

Updates 

Automatically check for updates for 

Snagit. If disabled, the user will not 

receive any application prompts 

when new versions are available. 

 

Note: Automatic updates now 

use Windows Background 

Intelligent Transfer Service 

(BITS) for improved user 

experience. Be sure BITS has 

internet access through your 

firewalls. 

Consider disabling if: 

• As an administrator, you want to 

maintain control of application 

updates across the organization 

and not allow users to install 

updates. 

• You want to require individual 

users or user groups to be on a 

specific version of the application. 

• You do not want the TechSmith 

Uploader Service to install during 

an update. 

Online Snagit 

Registration 

Dialog 

After installing, the Snagit 

Registration dialog appears which 

includes options to register the 

software online and sign up for 

product announcements, customer 

stories, and free tutorials. 

Disabling this option prevents the 

online registration dialog from 

displaying for users. 

 

Consider disabling this option to 

prevent user entered errors when 

registering the software or 

duplicating the registration 

information online. 

Webcam on 

by default for 

video capture 

The webcam is on by default the 

first time the user selects video 

capture mode. 

Consider disabling if you only want 

the webcam enabled when the user 

selects it. 
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Option Description When Should I Consider Disabling 
It? 

Printer 

Capture 

Snagit installs as a printer 

destination for programs with 

printing capability. 

 

The Printer Capture Option scans 

the document in a program and 

opens the capture in Snagit Editor. 

Consider disabling when deploying in 

a server environment (e.g. Remote 

Desktop Services). 

 

Note: If you disable Printer 

Capture, make sure to also disable 

the Snagit Printer option on the 

Install Features tab of the 

Deployment Tool. 

Online Help Snagit Tutorials and the TechSmith 

Help Center require an internet 

connection. They provide content 

to assist in getting started in Snagit 

and to find answers to product 

questions. 

Consider disabling if the TechSmith 

website is restricted in your 

organization or if users do not have 

an internet connection. Disabling this 

option opens the PDF list of available 

resources whenever users click Help 

links in Snagit. 

Disable 

welcome 

survey 

The two-question survey: 

• Helps TechSmith understand 

what users want to accomplish 

with the app. 

• Allows users to customize how 

they access Snagit Capture. 

Consider disabling if you do not want 

to influence app improvements, 

feature developments, or 

instructional resources available to 

Snagit users. 

 

https://www.techsmith.com/learn/tutorials/snagit
https://support.techsmith.com/
https://support.techsmith.com/
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Option Description When Should I Consider Disabling 
It? 

Share 

Manager 

The Share Manager allows users to 

update, add, or remove share 

destinations from Snagit. To access 

the Share Manager in Snagit Editor, 

select Edit > Editor Preferences 

> Share tab. 

Consider disabling if: 

• You select to redirect the 

destinations to a path other than 

the default. 

• You do not want to allow users to 

update the destinations. 

Local Crash 

Dump 

Collection 

Allow Snagit to write crash dumps 

to 

C:\Users\username\AppData\Local\

TechSmith\Snagit\CrashDumps\ for 

diagnostic purposes. If this is 

disabled, crash dumps are written 

to a temporary file. 

Consider disabling when you need to 

drive storage space. 

Hide Product 

Key 

Prevent Snagit from displaying the 

key in the Help menu > About 

Snagit > Support Information 

dialog. 

Consider disabling if you do not want 

users to be able to copy the key. 

Disable links 

to TechSmith 

Assets for 

Snagit service 

TechSmith Assets for Snagit, 

available at 

https://library.techsmith.com/, 

offers royalty-free stamps, 

templates, themes, and photos for 

download and use in Snagit.  

 

Select this option to prevent Snagit 

from showing references and links 

to Assets. 

Consider disabling if users do not 

have internet access or are in 

restricted environments that would 

prevent them from viewing and 

downloading assets. 

https://library.techsmith.com/
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Option Description When Should I Consider Disabling 
It? 

Disable 

Welcome 

Window with 

In-Product 

Tours 

Prevent Snagit from showing 

onboarding on initial launch. 

Consider disabling if: 

• You do not want to show new 

Snagit users basic app functionality. 

• You do not want to highlight new 

features for existing users. 

Disable 

anonymous 

usage 

reporting 

Snagit sends anonymous usage 

data to help TechSmith improve 

future versions.  

 

View the TechSmith Privacy Policy 

to learn more about our 

anonymous usage data collection. 

 

 

Consider disabling: 

• When you must follow internet 

security requirements that restrict 

users from sending data to 

TechSmith. 

• Or, if you do not want to 

participate in the feedback 

program. 

 

IMPORTANT: Disabling anonymous 

usage reporting also prevents users 

from viewing contextual onboarding 

and help content directly relevant to 

how they are using the app. When 

this option is selected, the Don’t 

show me notifications option is 

also selected automatically. 

https://www.techsmith.com/privacy-policy.html
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Option Description When Should I Consider Disabling 
It? 

In-app help 

and 

notifications 

Select the types of messages in 

Snagit to show users: 

• Don’t show any help or 

notifications: Notifications from 

TechSmith are disabled. This 

includes help and tips for using 

Snagit features.  

• Only show help tips: Includes 

contextual onboarding and help 

content directly relevant to how 

they are using the app 

• Show all tips and news from 

TechSmith 

Consider selecting Only show help 

tips if you do not want users to see 

webinar or other event 

announcements, survey/research 

invitations, or sales promotions. 

 

Note: Notifications require usage 

reporting. If the Disable 

anonymous usage reporting 

option is selected above, the Don’t 

show any help or notifications 

option is also selected 

automatically.  
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Option Description When Should I Consider Disabling 
It? 

Disable 

Experimental 

Features 

Users can be part of shaping 

Snagit’s roadmap by trying out new 

developments and sharing 

feedback.  

 

Users can turn individual 

experimental features on or off at 

any time in Snagit Editor by 

selecting Edit > Editor 

Preferences > Experiments tab. 

Consider disabling if you do not want 

users to access features that are still 

in development. 

 

Note: Experimental features 

require usage reporting. If the 

Disable anonymous usage 

reporting option is selected above, 

the Disable Experimental 

Features option is also selected 

automatically. 

 

Disable Integral Features – Not Recommended 
We strongly recommend against disabling any of the following features, which can significantly 

impact Snagit’s functionality. 
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Option Description When Should I Consider Disabling 
It? 

Image 

Capture 

Image captures take a snapshot of 

anything on your screen including a 

region, window, scrolling window, or 

the entire screen. 

Consider disabling: 

• If you want to disable image 

capture including image capture 

presets and options. 

 

IMPORTANT: Disabling Image 

Capture severely restricts the core 

functionality of the Snagit 

application. 

Video Record, trim unwanted sections, and 

playback MPEG-4 or Animated GIF 

videos in Snagit. 

Consider disabling: 

• If users are running Snagit on a 

computer that does not support 

video system requirements. 

• To allow an administrator to control 

resources (CPU/GPU/Bandwidth) 

when deploying in virtualized 

environments. 

 

IMPORTANT: Disabling Video 

severely restricts the core 

functionality of the Snagit 

application. 
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Option Description When Should I Consider Disabling 
It? 

TechSmith 

Account 

Sign-In 

TechSmith accounts store specific 

user-specific information such as 

license keys, your user profile, and 

Screencast login. See About 

TechSmith Accounts. 

• Sign in is not required for users 

when a single or multi-user key is 

entered in the Deployment Tool.  

• Signing into a TechSmith account 

allows users to share to Screencast. 

• You may consider disabling this 

option if you do not want to require 

users to have TechSmith accounts 

in your organization. 

 

IMPORTANT: Disabling TechSmith 

Account Sign-in severely restricts 

core functionality of the Snagit 

application. 

https://www.techsmith.com/about-techsmith-id.html
https://www.techsmith.com/about-techsmith-id.html
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Option Description When Should I Consider Disabling 
It? 

WebView2 

Check 

Prevent Snagit from checking for the 

installation of WebView2 and from 

displaying alerts if WebView2 is not 

detected. 

 

Note: WebView2 is required: 

To display enhanced tooltips. 

To display account information. 

If WebView2 Check is enabled, 

WebView2 Runtime must be 

installed “per machine” to be 

detected correctly on end-users’ 

computers See Installing the 

Runtime as per-machine or per-

user from Microsoft. 

• If you want to install your own 

supported version of WebView2. 

• Or, if you do not want Snagit to get 

the latest version of WebView2 

from Microsoft, which requires an 

internet connection at the time of 

installation. 

• Or, if you do not want to install 

WebView2 at all. 

 

IMPORTANT: Disabling WebView2 

Check severely restricts some core 

functionality of the Snagit 

application. 

 

 

 

 

 

Installation 

of SQL CE 

Prevent installation of Microsoft SQL 

CE libraries needed to convert users’ 

libraries from Snagit version 2021 and 

earlier. 

• Consider disabling when you need 

to reduce exposure to assemblies 

that are no longer supported (End 

of Life). 

 

IMPORTANT: Disabling SQL CE 

Installation prevents users from 

accessing files or importing backups 

from Snagit version 2021 or earlier. 

See Snagit Library Conversion Tool 

for more information. 

 

https://docs.microsoft.com/en-us/microsoft-edge/webview2/concepts/distribution#installing-the-runtime-as-per-machine-or-per-user
https://docs.microsoft.com/en-us/microsoft-edge/webview2/concepts/distribution#installing-the-runtime-as-per-machine-or-per-user
https://docs.microsoft.com/en-us/microsoft-edge/webview2/concepts/distribution#installing-the-runtime-as-per-machine-or-per-user
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Snagit Library Conversion Tool 

 

For organizations that cannot have unsupported SQL CE libraries on end users’ machines long-

term for compliance or other risk mitigation reasons, a separate Snagit Library Conversion Tool 

is available. This tool allows administrators to: 

 

1. Temporarily deploy SQL CE DLLs to end users’ machines; 

2. Convert users’ Snagit Libraries or import SNAGARCHIVE backup files from Snagit 2021 

and earlier; 

3. Uninstall the SQL CE DLLs when they are no longer needed. 

 

For more information, refer to the Snagit Library Conversion Tool Guide available on the 

TechSmith Software Deployment & Resources page. 

  

https://www.techsmith.com/resources/enterprise-resources/
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Install Features Options 

 

 

Snagit share destinations are add-ons to help users upload content to third-party websites and 

applications. The destinations appear in the Share dropdown in Snagit Editor. 
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Select which destinations are available to users. If you disable any of the options above, the 

destinations will not appear in the Share dropdown for the end user. 

 

For example, if YouTube is restricted in your organization, you may want to remove the 

destination in Snagit. 

 

Note: Sharing to Screencast and Slack require a TechSmith account. Sharing to these 

destinations will fail if the Disable TechSmith Account sign-in option is selected on the 

Disable Snagit Settings tab. 
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Option Description 

Snagit Printer Snagit installs as a printer destination for programs 

with printing capability. 

 

 

 

The Snagit Printer option scans the current document 

in a program and opens the capture in Snagit Editor. 

Windows Explorer Menu Extension Allows users to quickly send and convert images using 

Batch Export. To access Batch Export in Snagit Editor, 

select File > Export. 
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Option Description 

Share Destinations The destinations appear in the Share dropdown in 

Snagit Editor and allow users to share their captures to 

popular applications and cloud destinations. 

  

Microsoft Word Destination Allows users to insert an image into a Microsoft Word 

document. 

Microsoft Excel Destination Allows users to insert an image into a Microsoft Excel 

workbook. 

Microsoft PowerPoint Destination Allows users to insert an image or video into a 

Microsoft PowerPoint presentation slide. 
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Option Description 

Screencast Destination Allows users to upload an image or video to Screencast 

for hosting. Screencast provides a URL for quick 

sharing and the ability to add comments for feedback 

or collaboration. 

 

IMPORTANT: If you deselect the Screencast Share 

option, the Share Link functionality is disabled, and the 

Share Link button is replaced with a Share button. 

 

Camtasia Editor Destination Allows users to import an image or video into the 

Camtasia Editor media bin. 

Camtasia Online Destination Allow users to upload images to Camtasia’s online app. 

YouTube Destination Allows users to upload a video to YouTube for video 

hosting. YouTube provides a URL for quick sharing to 

your audience or an embed code for embedding the 

captures on a website or blog. 

Google Drive Destination Allows users to upload an image or video to Google 

Drive for image or video hosting. Snagit sends the 

share link to the Clipboard. 

Dropbox Destination Allows users to upload an image or video to Dropbox 

for image or video hosting. Snagit sends the share link 

to the Clipboard. 

OneDrive Destination Allows users to upload an image or video to OneDrive 

for image or video hosting. Snagit sends the share link 

to the Clipboard. 

Microsoft OneNote Destination Allows users to insert an image into a Microsoft 

OneNote notebook. 

https://www.techsmith.com/screencast.html
https://www.techsmith.com/camtasia/
https://camtasia.techsmith.com/
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Option Description 

Slack Destination Allows users to upload an image or video to a specific 

Slack channel or Direct Message. Snagit sends the 

share link to the Clipboard. 

Box Destination Allows users to upload an image or video to Box for 

image or video hosting. Snagit sends the share link to 

the Clipboard. 

Evernote Destination Allows users to upload an image to Evernote. 

Twitter Destination Allows users to upload an image or video to Twitter 

with a 280-character message. Snagit sends the share 

link to the Clipboard. 

SharePoint Destination Allows users to upload an image or video to SharePoint 

for image or video hosting. Snagit sends the share link 

to the Clipboard. 

Microsoft Teams Destination Allows users to send an image or video to a Teams 

Channel or Chat.  

 

An administrator must pre-approve the Snagit Share 

Destination before users can share from Snagit to 

Teams. See How to Pre-Approve the Snagit Teams 

Share Destination. 

FTP Share Destination Allows users to upload an image or video to an FTP 

server. 

 

  

https://support.techsmith.com/hc/en-us/articles/19598294359565
https://support.techsmith.com/hc/en-us/articles/19598294359565
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Force Installation of Microsoft Share Destinations 
Forces the installation of Microsoft Office share destinations when Snagit does not detect Office 

installed on the PC. Recommended for customized or cloud installations of Office. 

Customize Share Link Button 
The Share Link button is a one-click method to upload an image or video to a cloud service and 

copy the URL to the user’s clipboard for sharing. 

 

Customize the Share Link button to send the file to: 

• Screencast (default) – TechSmith’s cloud-based solution for content hosting and 

feedback. Snagit users have free access to Screencast to upload unlimited images and 

up to 25 videos.  

• OneDrive 

• Google Drive 

• None – This option disables the Share Link button.  
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TechSmith Fuse Options 

 

 

TechSmith Fuse is a mobile app that allows you to send images and videos from your mobile 

device directly to Snagit. You can capture, collaborate, and access your content - wherever you 

are. 

 

Fuse is available from the App Store or Google Play and supported on mobile devices running 

the following operating systems: 

• iOS version 13.6 and later (phones and tablets) 

• Android version 7.0 and later 

 

Note: Some security settings and wireless network environments may not allow connectivity 

to a desktop. Make sure to confirm port 8303 is open when working in a virtual environment. 

http://www.techsmith.com/redirect.asp?target=fuseappstore&ver=13.0.%2A&lang=enu&os=win&product=snagit
http://www.techsmith.com/redirect.asp?target=fusegoogleplay&ver=13.0.%2A&lang=enu&os=win&product=snagit
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User Data Paths Options 
 

 

You can change or customize the location for storing user data on the User Data Paths screen. 

 

Automatically Stored Files 
Snagit automatically saves all captures in the library folder. Select a location for this folder from 

the following options: 

 

• Default: %USERPROFILE%\Documents\Snagit\ 

• Custom location: Specify a local folder other than Documents. 

• Cloud location: Select a third-party cloud storage option. Snagit supports OneDrive for 

Business, OneDrive Personal, Box, Dropbox Business, Dropbox Personal, Google Drive, 

and iCloud. 
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o The third-party app must be installed on the user’s computer, meaning not 

accessed only by a web browser. 

o The application must be set to actively sync. For specific cloud service settings, 

see the Snagit Library Location tutorial. 

 

Note: It is possible, but not recommended, to set the library location to a network drive 

(either directly or indirectly via mapped folder). If the library location is set to a network 

drive: 

• File counts are not displayed. 

• Search is limited to file name. 

• Filter categories are not available. 

• Tagging is disabled. 

 

For full functionality specify a local, unmapped folder. 

 

To help prevent users from losing data and to limit users from changing the path, it is 

recommended to disable the option: 

• Allow user to change the automatically stored files location in Editor 

Preferences. 

 

This option for users to change the automatically stored file location is found in Snagit Editor 

> Edit > Editor Preferences > Library tab > Library location. 

 

Note: If the following conditions are both true: 

• The option to allow users to change the automatically stored files location is enabled. 

• The library location was set during a previous deployment or by the end user. 

Then Snagit will use the existing location and ignore any custom folder or cloud location 

specified here. 

 

 

  

https://www.techsmith.com/learn/tutorials/snagit/snagit-library-location/#cloud
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Other User Settings 
User settings such as quick styles, cached thumbnails, additions to the spelling dictionary, 

anonymous usage data files, etc. are stored by default in: 

%LOCALAPPDATA%\TechSmith\Snagit. 
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Add Components 

The components added are included in the Snagit installation. 

Presets 
Set up a preset to automatically remember your capture settings. Use presets to: 

• Save commonly used capture settings. 

• Eliminate the setup time before each capture. 

• Quickly switch between capture types based on the task at hand. 

• Reduce the editing required by automatically adding effects or selecting the share 

location. 
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To deploy Snagit with additional presets, add the exported Snagit Preset files (.snagpresets) on 

the Add Components screen. 

1. Export the Snagit Preset file (.snagpresets) in Snagit Editor. 



   

 

Snagit Deployment Tool Guide | 37  

 

2. On the Add Components screen, click the Add button. 

3. Browse and select the desired .snagpresets file. Control-click to select multiple files. 

4. Click Open. 

Tool Themes 
Themes provide a set of Quick Styles for each tool in Snagit Editor, for example to match your 

organization’s brand or marketing colors and font. To learn how to create and export custom 

themes, see the Snagit Themes tutorial.

https://www.techsmith.com/learn/tutorials/snagit/snagit-themes/
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To deploy Snagit with additional themes, add the exported theme files (.snagtheme) on the Add 

Components screen. 

1. Export the theme file (.snagtheme) in Snagit Editor. 

2. On the Add Components screen, click the Add button. 

3. Browse and select the desired .snagtheme file. Control-click to select multiple files. 

4. Click Open. 
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Snagit Registry File Options 
 

 

The registry file contains custom settings within the Snagit application such as presets, 

appearance settings, and hotkeys. 

 

Some of these custom settings are located in the following locations: 

• In the Capture Window, select File > Capture Preferences. 

• In Snagit Editor, select Edit > Editor Preferences. 

 

Note: Stamps, Quick Styles, and options in the toolbar are not stored in the registry 

file and cannot be deployed to multiple users. 

 

To deploy custom Snagit settings to multiple users: 



   

 

Snagit Deployment Tool Guide | 40  

1. Install Snagit. 

2. Set up Snagit with the desired settings and customizations for your organization. 

3. Close Snagit. 

4. Run Command Prompt as an administrator. 

5. Make sure Snagit is not running. To create the Snagit registry file on your desktop, enter 

the following into the Command Prompt: 

"C:\Program Files\TechSmith\Snagit\SnagitCapture.exe" /e 

%userprofile%\Desktop\Snagit.reg 

6. In the TechSmith Deployment tool, click the Snagit Registry File tab and select 

Customize Snagit registry settings by importing a Snagit.reg file. 

7. Click the Browse button to select a Snagit.reg file produced in step 5. 

The transform (MST) file generated from the Deployment Tool will use the settings from 

the registry as the default settings when installing Snagit. 
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Uninstall Options 
 

 

Keep or Delete Files 
When uninstalling Snagit, there are three options for users' current Snagit customization files 

(capture presets, favorites, toolbar customizations, quick styles, themes, color palettes, and 

share preferences). If you plan to reinstall or upgrade Snagit for a user, we recommend 

selecting the Keep Files option. 

 

Select one of the following options on the Uninstall Options screen: 

• Prompt users with this dialog: When uninstalling Snagit, allow the user to select 

whether to keep or delete their current Snagit customization file
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• Keep files: Automatically keep the user’s customization files when uninstalling Snagit. 

Users are not prompted with this dialog. 

• Delete files: Automatically deletes the user’s customization files when uninstalling 

Snagit. Users are not prompted with this dialog. 

Uninstall Previous Versions 
The UninstallerTool.exe is embedded in the TechSmith Deployment Tool. To download, see 

Download the Deployment Tool. 

 

You can uninstall previous versions using: 

• Uninstaller in the Deployment Tool 

• Uninstaller Tool Command Line 

 

Note: To uninstall previous versions without deploying a new version of Snagit, see the 

support article Use the Snagit UninstallerTool.exe as a Command Line Tool. 

 

Uninstall Previous Versions using the Deployment Tool 
Note: The embedded uninstaller tool was updated to handle the new WiX 64-bit installers. 

Uninstaller tools in older versions of the Deployment Tool will not be able to uninstall Snagit 

version 2025 or later. 

 

1. Download the Snagit MSI file and the TechSmith Deployment Tool. 

2. Double-click the TechSmith_Deployment_Tool.exe to launch the program. 

 

3. On the Welcome screen, click the Open MSI Package button. 

4. Select the Snagit.msi file. 

5. Click Open. 

6. On the Uninstall Options screen, select an uninstall option: 

https://support.techsmith.com/hc/en-us/articles/360022581532-Use-the-Snagit-UninstallerTool-exe-as-Command-Line-Tool
https://download.techsmith.com/snagit/releases/snagit.msi
https://download.techsmith.com/tscdeploymenttool/techsmith_deployment_tool.exe
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• Uninstall all previous versions 

• Uninstall only: Uninstalls specific versions of Snagit. Enter the Snagit major 

version number. Separate versions by a comma. Make sure to enter the 2 digit 

version number (e.g. 20 not 2020). 

7. Select the other desired options in the Deployment Tool for installing the new version 

of Snagit. 

8. On the Create Transform screen, enter the file path and click Create Transform. 

9. The tool is extracted to the Batch file location selected. Copy the MSI, MST, BAT and 

UninstallerTool.exe files to a folder on the target machine. 

You must copy the BAT and UninstallerTool.exe files to the same folder and 

update the file paths in the BAT file to match the folder location. 

 

10. Open a command prompt with elevated Admin privileges. 

11. Run the batch file to uninstall previous versions of Snagit and then install the new 

version. 

You cannot right-click the BAT file and select Run as administrator to elevate file 

privileges. 

 

Note: In some instances, the target machine must be rebooted to uninstall older versions. A 

message is shown if a reboot is required. 

Uninstall Previous Version using Command Line 
The Uninstaller tool can be run independently or as part of the Deployment Tool process. Make 

sure to: 

• Run the command prompt with elevated Admin privileges. 

• Use version 1.2.0.x or later of the Uninstaller tool. 

 

Flags and parameters: 

-product <insert product_name> 

-keep <insert comma-separated version list> 

-remove <insert comma-separated version list> 

-log <log_file_name> 
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Examples: 

1. Remove all versions of Snagit: 

UninstallerTool.exe -product snagit 

2. Remove only versions 2019 and 2021 of Snagit: 

UninstallerTool.exe -product snagit -remove 19, 21 

3. Remove all versions of Snagit except 2019 and 2021: 

UninstallerTool.exe -product snagit -keep 19, 21 

4. Specify a log file for the uninstaller output: 

UninstallerTool.exe -product snagit -log uninstallerLog.txt 

 

By default, the Uninstaller tool writes progress information to the standard output; use the "-

log" flag to output to a named file instead. Windows installer log files are created for each 

version of Snagit that is uninstalled. Windows installer log files can be found in the following 

locations: 

• MSI installer logs: Located in the same folder as the Uninstaller tool and are in the 

form of "Uninstall_<version>_Log.txt" 

• EXE installer logs: Located in "%localappdata%\temp" with a file name in the form of 

"Snagit_<version>_ SnagitInstaller_<platform>.log" 
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Install Display Options 

 

 

Select one of the following options: 

• Quiet display: Installs Snagit silently with no setup interface displayed. May be run 

from a non- administrator command prompt. It will not return the command prompt 

until Snagit has finished installing. 

• Passive display: Installs Snagit from an administrator command prompt. It returns the 

command prompt immediately (non-blocking). The minimal setup is displayed and 

Snagit notifies the user when the installation is complete.
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Create Transform File 

 

 

1. Select I have read and accept the End User License Agreement checkbox. 

2. Click the Create Transform button to generate the following files based on the 

options selected within the Deployment Tool: 

• Transform file (MST) 

• Batch Processing file (BAT) 

 

IMPORTANT: Special characters are not supported in the file path and will prevent successful 

deployment.
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Additional Resources 

Enterprise Resources 
TechSmith Software Deployment & Resources website 

Download other resources and guides to assist with Snagit enterprise installations. 

 

Technical Support 
We're here for you! Visit the Technical Support website to submit a ticket, find answers online, 

or contact an expert. 

https://www.techsmith.com/enterprise-resources.html
https://support.techsmith.com/hc/en-us
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