System Requirements

Mobile Requirements

To download the TechSmith Fuse app, your mobile device must meet these requirements.
iOS: version 7+
Android: version 4.0+

 

Connecting to Snagit

Mac OS X System Requirements

Connecting to Camtasia

Mac OS X System Requirements

  • Users must be on version 2.6+
  • TechSmith Fuse can only upload over a WiFi connection
  • TechSmith Fuse must be on the same network as Camtasia for Mac
  • More Camtasia system requirements

Connecting to TechSmith Knowmia (formerly TechSmith Relay)

 

TechSmith Knowmia